Cost-Saving Compatible Canon FB5-4942-000 Lower Fuser Pressure Roller

For Use With:

  • Canon imageRUNNER iR 2200
  • Canon imageRUNNER iR 2200G
  • Canon imageRUNNER iR 2200i
  • Canon imageRUNNER iR 2200N
  • Canon imageRUNNER iR 2220i
  • Canon imageRUNNER iR 2220N
  • Canon imageRUNNER iR 2800
  • Canon imageRUNNER iR 2800G
  • Canon imageRUNNER iR 2800i
  • Canon imageRUNNER iR 2800N
  • Canon imageRUNNER iR 3300
  • Canon imageRUNNER iR 3300G
  • Canon imageRUNNER iR 3300i
  • Canon imageRUNNER iR 3300N
  • Canon imageRUNNER iR 3320G
  • Canon imageRUNNER iR 3320i
  • Canon imageRUNNER iR 3320N

  1. 0 votes
    Q whether it is compatible for canon IR2002n printer?
    Asked on May 24, 2019 11:42 AM
    There are no answers for this question yet. Answer now
  2. 0 votes
    Q Prizes reduced
    Asked on November 4, 2018 10:19 AM
    There are no answers for this question yet. Answer now

Send me a notification for each new answer.
Cart Item Removed. Undo
  • No products in the cart.
Loading...